Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ApacheGallery] New Debian package: Conflicts Apache1.3 ?



On Tue, 19 Jul 2005, Jesus Climent wrote:
> Since Debian does not allow conditional dependencies [1], i am
> thinking about doing the new package of Apache::Gallery incompatible
> with Apache1.3, so that only can be installed with Apache2

Please don't; some of us still like apache 1.3. 

> In the current implementation, it reads:
> 
> Depends: Apache1.3 _OR_ Apache2, libapache-mod-perl _OR_ libapache2-mod-perl2

Why bother to do this? 

Why not just depend on libapache-mod-perl or libapache2-mod-perl2?

libapache2-mod-perl2 and libapache-mod-perl should depend on the
appropriate version of apache; I'm not quite sure why they don't do so
now. [Probably a bug.]

> so Apache2 and libapache-mod-perl do install together, but dont play
> nice. Also, both v1 and v2 of mod perl can be installed in the same
> machine, which makes a::g not work.

What would be ideal is to figure out what version of mod_perl the
script is running under, and then load the appropriate modules to make
it work. I personally haven't looked at it recently, but I can't
remember anything that would make this impossible.


Don Armstrong

-- 
Miracles had become relative common-places since the advent of
entheogens; it now took very unusual circumstances to attract public
attention to sightings of supernatural entities. The latest miracle
had raised the ante on the supernatural: the Virgin Mary had
manifested herself to two children, a dog, and a Public Telepresence
Point.
 -- Bruce Sterling, _Holy Fire_ p228

http://www.donarmstrong.com              http://rzlab.ucr.edu
_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers