Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] Apachegallery on debian testing



It was brought to my attention this past weekend that my gallery is
broken, and apparently has been that way for some time.  Looks like
a debian upgrade sometime in the past N months bit me.

The problem is the same that others have reported on other mailing
lists:

libapache-gallery-perl 0.99-svn050524-1
apache2 2.0.54-4
apache2-common 2.0.54-4
apache2-utils 2.0.54-4
libapache2-mod-perl2 1.999.21-1

When someone hits a A::G url, I get the following in my logs:

[Mon Aug 08 13:08:51 2005] [error] [client 66.249.65.162] failed to
resolve handler `Apache::Gallery': Can't locate Apache2/ServerRec.pm in
@INC (@INC contains: /usr/lib/perl5/Apache2 /etc/perl
/usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache2) at
/usr/share/perl5/Apache/Gallery.pm line 23.\nBEGIN failed--compilation
aborted at /usr/share/perl5/Apache/Gallery.pm line 43.\nCompilation
failed in require at (eval 3) line 3.\n

The only outstand bug that I've seen is this:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=316172

...though I'm not sure it is in any way related to mine.

I've tried a number of tricks but none seem to solve the problem or
simply introduce more.

Is this a bug in Apache::Gallery that can be fixed and/or worked around?

Thanks!

-jon


_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers