Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [ApacheGallery] Libapache-galleryperl, Apache 2.0.54 and Debian 3.1



 
I just installed libapache2-mod-perl2, it says you have to do a
force-reload.

After that reload everything works fine, but when I enable the gallery
virtualhost it's still giving problems
No more problems at the command line, but the following:

(one line)

[Mon Jul 04 17:29:55 2005] [error] [client 192.168.0.10] failed to resolve
handler `Apache::Gallery': Can't locate Apache2/ServerRec.pm in @INC (@INC
contains: /usr/lib/perl5/Apache2 /etc/perl /usr/local/lib/perl/5.8.7
/usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .
/etc/apache2) at /usr/share/perl5/Apache/Gallery.pm line 23.\nBEGIN
failed--compilation aborted at /usr/share/perl5/Apache/Gallery.pm line
43.\nCompilation failed in require at (eval 3) line 3.\n

I've searched for ServerRec.pm, and it's in:

/usr/lib/perl5/Apache2/Apache

I re-installed my devserver today, so that's why mod_perl was not installed,
but yesterday I had the same problem with the .pm files. When I copy
ServerRec.pm to /usr/lib/perl5/Apache2 it's asking for another pm file.
After you've copied all the .pm files to this directory, it gives an other
problem, but I don't know wich one.

When I try to reach it on the internet, I get an internal server error
message.

Kind regards,

Willem-Jan Meijer
http://www.computerdokter-groenlo.nl 


-----Oorspronkelijk bericht-----
Van: Jesus Climent [mailto:[email protected]] 
Verzonden: maandag 4 juli 2005 17:09
Aan: Willem-Jan Meijer
Onderwerp: Re: [ApacheGallery] Libapache-galleryperl, Apache 2.0.54 and
Debian 3.1

On Mon, Jul 04, 2005 at 04:56:26PM +0200, Willem-Jan Meijer wrote:
> Hello list,
> 
> I have some troubles setting up Aapache::Gallery. I'm using the 
> testing-version of Debian, and installed it with dselect, so not from 
> scratch.
> It solves dependency problems, so I thought it would be quite easy. 
> It's giving problems getting it work, as at this moment, with the 
> virtualhost for gallery not commented out apache isn't working at all.

Have you activated perl-mod?

use "a2enmod" 

-- 
Jesus Climent                                      info:www.pumuki.org
Unix SysAdm|Linux User #66350|Debian Developer|2.6.10|Helsinki Finland
GPG: 1024D/86946D69 BB64 2339 1CAA 7064 E429  7E18 66FC 1D7F 8694 6D69

Sick as a dog. Gonna vomit.
		--Dr. Evil (Austin Powers: The Spy Who Shagged Me)

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers