Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] Documentation bug and no warning result in empty page



(My first attempt to send this message bounced because I followed the
instructions from the agusers list confirmation e-mail and sent this to
agusers rather than users.)

Hello!  I'm a huge fan of A::G.  It's exactly what a gallery should be, no
more, no less.

I wanted to let you know about my installation ordeal that nearly made me
give up on A::G.  Hopefully this will save someone else some time.

From the INSTALL file, there is the following config line:

PerlSetVar   GalleryTemplateDir '/usr/local/apache/gallery/templates'

I adapted this line to point to where I copied the templates directory.
Then I eagerly fired up Apache, accessed the page, and it was blank.  I
looked at the HTML source, and it was empty.  I looked at my Apache
error_log and there were no messages.  I was completely mystified.

I'm not sure how I finally figured it out.  I think I traced through the
source code to analyze what was going wrong.  I finally figured out that
the templates directory was invalid.  I simply modified GalleryTemplateDir
to point to

/usr/local/apache/gallery/templates/default

and then it worked.  I can't imagine I'm the only one this has happened
to, although I couldn't find anything in the forums.

I would recommend the following for the next version:
1.  Change the line in INSTALL to point to templates/default
2.  Display a warning message when the templates directory is invalid

I hope you keep up the fabulous work.  It is greatly appreciated!  Thank
you!

Sincerely,
B. Mares

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers