Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] Need help! Thumbnail sizes



Hello,
I posted this once before, but never received any response.
The thumbnail size settings are not working for me. If I set thumbnail size
to 100x100, logic dictates that both constraints should be met ( width <=
100 && size <=100 ). However, the code seems to only ensure that one of
these criteria is met. Could someone please point me to the area in the
source where this check is implemented (I'm not a Perl guy, I work with Java
mostly, so non-OO code freaks me out) so that I can fix it? Is it a problem
with the image size library that's listed as a dependency?

I think Apache:Gallery is a great tool, but without true control over image
sizes, it's not very useful in a production setting.

Thanks,
David Gee

----- Original Message ----- 
From: "Tom Utley" <[email protected]>
To: "Andreas Plesner Jacobsen" <[email protected]>
Cc: <[email protected]>
Sent: Friday, August 29, 2003 8:59 AM
Subject: Re: [ApacheGallery] Random Images do not create thumbnails


> Http://gallery.tomutley.com has absolutley no problems, and plenty of
jpegs are in there, both
> vertical and horizontal. It's the same installation on the same server.
(different virtual servers
> of course)
>
> I'm running redhat 7.2 and gallery .6 I believe.
>
> Andreas Plesner Jacobsen wrote:
> > On Fri, Aug 29, 2003 at 08:54:27AM +0200, Andreas Plesner Jacobsen
wrote:
> >
> >>Which Linux distribution are you running? It would seem that you don't
> >>have all the prerequisite packages installed (for example: jpeg and/or
> >>png libs)
> >
> >
> > Or with the case being that you actually are able to read some images,
> > your libjpeg or imlib2 installation may be broken.
> >
>
>
> -- 
> Present Sense
> Tom Utley
> President
> http://presentsense.com/
>
>