Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ApacheGallery] Apache::Server with mod_perl/1.99 -> on Trustix



Hi,

Here you can find how to get the latest A::G working on
Trustix (www.trustix.net) with Apache 2.0.54 /mod_perl 2.x:

On Tue, May 24, 2005 at 07:17:36PM +0200, Michael Legart wrote:
> No, sorry.. The problem is that the API changed between 
> 1.99_22 (I think it was) and older versions.I think distributions will include
> 2.0 very soon now that it is finally stable.

Trustix released mod_perl 2.0.0 a couple of weeks ago.
I installed everything for A::G as the INSTALL says in
http://svn.apachegallery.dk/svn/gallery/trunk .

It all worked OOTB except for one thing: the apache error_log said:
"Image::Imlib2 load error: No loader for ..." 

You need to know Trustix has a very strict umask (0077).
Before I install anything from i.e. cpan I do # umask 0022; cpan
(or change it permanent in /etc/profile)
The Trustix upgrade tool is called swup. But a swup --install imlib2
made /usr/lib/imlib2 "rwx------ root root" ...
After manually changing this to 755 all went ok.

Hope these 2 cents helps a bit for Trustix users.

Regards,
Oscar "A::G much faster then linpha...:)" Buse
Netherlands.

History:
> On 5/24/05, Ozzie <[email protected]> wrote:
> > On Tue, May 24, 2005 at 10:07:19AM +0200, Michael Legart wrote:
> > > Hi!
> > >
> > > This has been fixed in trunk
> > >
> > > http://svn.apachegallery.dk/svn/gallery/trunk/
> > 
> > Thanks!
> > But mod_perl/1.99_17 (which i currently have) is now
> > no option at all(?):
> >         if ($mod_perl::VERSION >= 1.99 && $mod_perl::VERSION < 2.0) {
> >                 "die mod_perl 2.0.0 or later is now required";
> >         }
> > 
> > Or has it never been?
> > I guess I need to upgrade to 2.0.0 or later...
> > Unfortunately I run the latest Trustix with automatic software installer
> > and mod_perl is at 1.99_17.
> > Anyway, if I can find the time I'll testdrive the new version and let you know.
> > 
> > Gr.,
> > Oscar.
> > 
> > > On 4/26/05, Oscar Buse <[email protected]> wrote:
> > > > Hi,
> > > >
> > > > I just installed A::G 0.9.1 with all the packages on
> > > > Apache/2.0.54, mod_perl/1.99
> > > >
> > > > make test gives:
> > > > Error:  Can't locate Apache/Server.pm in @INC (...)
> > > >
> > > > And indeed in Gallery.pm:
> > > >        if ($::MP2) {
> > > >                 require Apache2;
> > > >                 require Apache::Server;
> > > >                 ...
> > > >
> > > > But isn't Apache::Server (cpan: G/GO/GOZER/mod_perl-1.29.tar.gz)
> > > > about mod_perl/1 ??
> > > >
> > > > I'm confused...or am I just plain stupid??
> > > >
> > > > I'm running:
> > > > Server: Apache/2.0.54 (Trustix Secure Linux/Linux) mod_perl/1.99_17 Perl/v5.8.5 PHP/5.0.4
> > > > and all the req'd packages as mentioned in the INSTALL.
> > > >
> > > > --
> > > > Kind regards,
> > > > Oscar Buse
> > > > The Netherlands
> > > >
> > > > I have this nagging fear that everyone is out to make me paranoid.
> > > > _______________________________________________
> > > > users mailing list
> > > > [email protected]
> > > > http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers
> > > >
> >
_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers