Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ApacheGallery] Blank page



On Fri, 05 Nov 2004, Juan Pablo Pincheira wrote:
> Hi guyz. Well, I'm having a problem with apache::gallery, because I
> can't view it, when I access to http://localhost/gallery , it shows me
> an empty page. I have view my error_log of apache2, but I didn't view
> errors about this.
> 
> I've installed libapache-gallery-perl 9.1 (by debian package) and all
> his dependences.
> 
> My httpd.conf is this:
> 
> <Location /gallery>
> AllowOverride All
> SetHandler modperl
> PerlResponseHandler Apache::Gallery
> PerlOptions +GlobalRequest
> PerlSetVar GalleryTemplateDir '/usr/local/www/data/templates'
> PerlSetVar GalleryCopyrightImage '/usr/local/www/data/templates/copy.png'
> PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash =>
> Flash, Shutter Speed => ShutterSpeedValue'
> PerlSetVar GallerySortBy mtime
> </Location>
> 
> All directories are ok, the templates, my /gallery, all xD

The template isn't correct if you're using the debian
libapache-gallery-perl package.
 
It should be /usr/share/libapache-gallery-perl/templates/default/



After seeing to many of such e-mails, its come to my attention that I
should have added warnings and errors when Text::Template fails. I'll
prepare a patch to do that over the weekend.


Don Armstrong

-- 
Fate and Temperament are two words for one and the same concept.
 -- Novalis [Hermann Hesse _Demian_]

http://www.donarmstrong.com              http://rzlab.ucr.edu
_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers