Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] problem installing



I am just trying to get Apache::Gallery installed on my lowly web server so I
can display nice scaled pictures of my family.  When I do this I get the
following error:

PERL_DL_NONLAZY=1 /usr/local/bin/perl -Iblib/arch -Iblib/lib -I/usr/local/lib/perl5/5.6.1/i86pc-solaris -I/usr
/local/lib/perl5/5.6.1 test.pl
1..1
Can't locate object method "request" via package "Apache" (perhaps you forgot to load "Apache"?) at blib/lib/Apache/Gallery.pm line 23.
BEGIN failed--compilation aborted at blib/lib/Apache/Gallery.pm line 27.
Compilation failed in require at test.pl line 10.
BEGIN failed--compilation aborted at test.pl line 10.
make: *** [test_dynamic] Error 255
  /usr/local/bin/make test -- NOT OK

Some background:

OS- solaris 2.8 on intel platform
using Apache 1.3.22 with mod_perl compiled statically.
using Perl 5.6.1 installed from sunfreeware package
to get the above error I do a perl -MCPAN -e shell then do an install Apache::Gallery

I'm also having problems getting imlib2 to install...

configure: warning: *** Native JPEG support will not be built (JPEG library not found) ***
checking for png_read_info in -lpng... no
configure: warning: *** Native PNG support will not be built (PNG library not found) ***
checking for e_db_open in -ledb... no
configure: warning: *** Native EDB support will not be built (EDB library not found) ***
checking for TIFFReadScanline in -ltiff... yes
checking for tiffio.h... yes
checking for DGifOpenFileName in -lungif... no
checking for DGifOpenFileName in -lgif... no
configure: warning: *** Native GIF support will not be built (GIF library not found) ***
configure: error:
Fatal Error: No JPEG Headers AND Library detected.
             This is a minimum requirement
             (at least a JPEG, PNG and DB loader need to be built)
             All other loaders are optional

AAAARRRGGHHHH!!!!!   this is ridiculous!!

Do I have to be a dang developer to understand all the dependencies to install this perl module?
Can someone out there point me to a resource that will tell me from A to Z what I need to install to get Apache::Gallery working?? I've been at this for 2
days now
and still no closer to getting it to work.  Now I'm no idiot (the wife would sometimes disagree) but I just don't know how to resolve all these errors??  I
swear
I installed the graphics libraries before but I reinstalled from source anyways and it STILL says I don't have them installed!!  Do I need to point imlib2
somewhere to find them?  I tried using configure --with-gnu-ld option because I remember installing that before- no go.

I'm at my wits end here- I have NEVER had this much trouble getting something compiled and working.  Any help would be GREATLY appreciated!!

Regards,
Eric Steed



---------------------------------------------------------------------
Apache::Gallery users mailinglist. http://apachegallery.dk/
To unsubscribe, e-mail: [email protected]