Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [ApacheGallery] Libapache-galleryperl, Apache 2.0.54 and Debian 3.1



When I create a symlink from /usr/lib/perl5/Apache2/Apache
To
				 /usr/lib/perl5/Apache2/Apache2

Gallery.pm can find the module, but then I get this error message:

[Tue Jul 05 11:20:22 2005] [error] [client 192.168.0.10] failed to resolve
handler `Apache::Gallery': Subroutine load redefined at
/usr/lib/perl5/Apache2/Apache/XSLoader.pm line 28.\nCompilation failed in
require at /usr/lib/perl5/Apache2/Apache2/ServerRec.pm line 24.\nBEGIN
failed--compilation aborted at /usr/lib/perl5/Apache2/Apache2/ServerRec.pm
line 24.\nCompilation failed in require at
/usr/share/perl5/Apache/Gallery.pm line 25.\nBEGIN failed--compilation
aborted at /usr/share/perl5/Apache/Gallery.pm line 45.\nCompilation failed
in require at (eval 3) line 3.\n

I don't know what to do now, i'm not a programmer.


Kind regards,

Willem-Jan Meijer
http://www.computerdokter-groenlo.nl 

-----Oorspronkelijk bericht-----
Van: [email protected] [mailto:[email protected]]
Namens Willem-Jan Meijer
Verzonden: dinsdag 5 juli 2005 11:09
Aan: [email protected]
Onderwerp: RE: [ApacheGallery] Libapache-galleryperl, Apache 2.0.54 and
Debian 3.1

Both were installed, shame on me :D

I purged it, but still no result without modifying gallery.pm

The error message without libapache-mod-perl but with libapache2-mod-perl2:

[Tue Jul 05 11:06:00 2005] [error] [client 192.168.0.10] failed to resolve
handler `Apache::Gallery': Can't locate Apache2/ServerRec.pm in @INC (@INC
contains: /usr/lib/perl5/Apache2 /etc/perl /usr/local/lib/perl/5.8.7
/usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .
/etc/apache2) at /usr/share/perl5/Apache/Gallery.pm line 23.\nBEGIN
failed--compilation aborted at /usr/share/perl5/Apache/Gallery.pm line
43.\nCompilation failed in require at (eval 3) line 3.\n

It's still searching for Apache2/ServerRec.pm, but with a standard debian
installation by apt-get and dselect, it's in /Apache2/Apache/ServerRec.pm


Kind regards,

Willem-Jan Meijer
http://www.computerdokter-groenlo.nl 

-----Oorspronkelijk bericht-----
Van: Jesus Climent [mailto:[email protected]]
Verzonden: maandag 4 juli 2005 18:45
Aan: Willem-Jan Meijer
Onderwerp: Re: [ApacheGallery] Libapache-galleryperl, Apache 2.0.54 and
Debian 3.1

On Mon, Jul 04, 2005 at 06:35:30PM +0200, Willem-Jan Meijer wrote:
>  
> I checked it, but the module is loaded in Apache.
> Still no good, when I add the following line to gallery.pm:

The libapache-mod-perl should not be installed in the system, or otherwise
it does not work.

Can you check it if you have it there?

-- 
Jesus Climent                                      info:www.pumuki.org
Unix SysAdm|Linux User #66350|Debian Developer|2.6.10|Helsinki Finland
GPG: 1024D/86946D69 BB64 2339 1CAA 7064 E429  7E18 66FC 1D7F 8694 6D69

He's almost a stranger, and I prefer him to you!
		--Sandra Bloom (Big Fish)

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers