Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] XSLoader.pm



I'm trying to configure Apache::Gallery on FreeBSD 5.2.1 but get an error in XSLoader.pm All prerequests have been installed from ports including mod_perl (although it isn't found)
Some help would be apreciated

core# perl Makefile.PL
Warning: prerequisite mod_perl 0 not found.
Writing Makefile for Apache::Gallery
core# make
Manifying blib/man3/Apache::Gallery.3
core# make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/001_use...........NOK 1# Failed test (t/001_use.t at line 3) # Tried to use 'Apache::Gallery'. # Error: Subroutine load redefined at /usr/local/lib/perl5/site_perl/5.8.5/mach/Apache2/Apache/XSLoader.pm line 28. # Compilation failed in require at /usr/local/lib/perl5/site_perl/5.8.5/mach/Apache2/Apache/ServerRec.pm line 24. # BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.8.5/mach/Apache2/Apache/ServerRec.pm line 24. # Compilation failed in require at /tmp/ap091/blib/lib/Apache/Gallery.pm line 23. # BEGIN failed--compilation aborted at /tmp/ap091/blib/lib/Apache/Gallery.pm line 43.
# Compilation failed in require at (eval 3) line 2.
# Looks like you failed 1 tests of 1.
t/001_use...........dubious
       Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 1

t/006_thumbnails....dubious
       Test returned status 255 (wstat 65280, 0xff00)
t/007_pod...........skipped
       all skipped: Test::Pod v0.95 required for testing POD
Failed Test        Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/001_use.t           1   256     1    1 100.00%  1
t/002_graphlibs.t   255 65280    ??   ??       %  ??
t/003_comment.t     255 65280     2    4 200.00%  1-2
t/004_cache_dir.t   255 65280    ??   ??       %  ??
t/005_imageinfo.t   255 65280    ??   ??       %  ??
t/006_thumbnails.t  255 65280    ??   ??       %  ??
1 test skipped.
Failed 6/7 test scripts, 14.29% okay. 3/3 subtests failed, 0.00% okay.
*** Error code 2

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers