Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ApacheGallery] Debian server for A::G?



I installed libpng-devel and reinstalled Image::Imlib with "perl -MCPAN -e
'force install Image::Imlib2'" 

No luck.  Why would imlib2 still not recognise pngs?  btw, this worked fine under the older Inline::C implementation.

I've tried all kinds of rebuilds and such with cpan, in attempts to get this all
to work.

Signed, your Redhat 8.0 QA monkey:  Zak

On Tue, 30 Sep 2003 [email protected] wrote:

> Michael,
> 
> Yeah I think you're right about Imlib2 not supporting the file format in
> question.  Which is in this case png.  Strange though.  I have the libpng rpm
> installed... I'll try installing libpng-devel and then reinstalling Imlib2.
> 
> On Tue, 30 Sep 2003, Michael Legart wrote:
> 
> > Zak
> > 
> > On Tue, Sep 30, 2003 at 02:34:22PM -0700, [email protected] wrote:
> > > 
> > > [Tue Sep 30 14:14:56 2003] [error] [client 63.251.211.5] Image::Imlib2 load
> > > error: No loader for file format at
> > > /usr/lib/perl5/site_perl/5.8.0/Apache/Gallery.pm line 1203.!, referer:
> > > http://www.mode3.com/zak/pics/
> > 
> > Looks like your Imlib2 installation does not support the fileformat you
> > are trying to load? Is libjpeg and libpng installed? 
> > 
> > > When I look at some of my directories.  I get an Error 500 at the same time. 
> > 
> > With the error above being logged?
> > 
> > > [Tue Sep 30 14:33:26 2003] [error] [client 63.251.211.5] File does not exist:
> > > /home/zak/web/pics/Home/.cache, referer: http://www.mode3.com/zak/pics/Home/[Tue
> > > 
> > > What's up with that?
> > 
> > Seen that too - very strange.. investigating.
> > 
> > /Michael
> > 
> > 
> 
> 

-- 

Zak Brown 
www.mode3.com

--

"I'm not one of those button luddites that's all like anti-zipper."

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers