Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] Image:Imlib2 compile errors



Hi all!

After using A::G 0.6 for quite a while now, I wanted to give the latest
snapshot (r205) a try.

When installing Image::Imlib2 (thru CPAN) I get a missing lib error
from ld:

gcc -shared -L/usr/local/lib -o blib/arch/auto/Image/Imlib2/Imlib2.so lib/Image/Imlib2.o -L/usr/lib -lImlib2 -lttf -lm -ldl -lXext -lXext -lX11 -L/usr/X11R6/lib
/usr/bin/ld: cannot find -lttf

I'm not so into linux compiling, but I assume it's looking for
something like libttf in /usr/lib.

ls /usr/lib/*ttf*  gives this:

/usr/lib/libttf.la
/usr/lib/libttf.so.2
/usr/lib/libttf.so
/usr/lib/libttf.so.2.3.0

So what am I missing here. Any version requirements not met? What
package does libttf belong to?

Thanks for your patience with a linux beginner...

martin

using:
rh 7.3
apache 1.3.27
perl 5.6.1
imlib2 1.0.6

_______________________________________________
users mailing list
[email protected]
http://ufo.hestdesign.com/cgi-bin/mailman/listinfo/agusers