Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] Re: Installing under Apache 2



[email protected] writes:
Hmmmmm, there must've been something else that I installed that I didn't note. Ah, maybe it was libapreq that's still missing. rpm -Uvh --force ftp://rpmfind.net/linux/PLD/current/dists/ra/PLD/SRPMS/SRPMS/libapreq-1.0-3.src.rpm
rpmbuild -bi /usr/src/redhat/SPECS/libapreq.spec
I'm thinking that part of my problem is that I built Apache 2 and mod_perl
from source. When I try the rpmbuild I get:
apache-mod_perl >= 1.26-5 is needed by libapreq-1.0-3
Downloading the libapreq 1.0 source yields:
 [[email protected] libapreq-1.0]# perl Makefile.PL
 Can't locate Apache/MyConfig.pm in @INC (@INC contains:
 /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
 /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
 Makefile.PL line 27.
 BEGIN failed--compilation aborted at Makefile.PL line 27.
Same error when trying to install libapreq-1.1. Trying libapreq-1.2 tells me:
 [[email protected] libapreq-1.2]# perl Makefile.PL
 mod_perl 1.x ( < 1.99) is required at Makefile.PL line 29.
BEGIN failed--compilation aborted at Makefile.PL line 31. I guess the bottom line is, it can be done but it ain't trivial!
--------------------------
Dan Mahoney
[email protected]
"How you behave towards cats here below determines your status in Heaven."
Robert Heinlein
"There are two means of refuge from the miseries of
life - music and cats" - Albert Schweitzer