Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ApacheGallery] apache::gallery 0.6 display problems



I upgraded from 0.5 to 0.6.
The old one worked perfect. 0.6 doesn't want to.
 
-> The error log shows me imlib2 error messages
 
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:
 
        imlib_free_image();
 
        With the parameter:
 
        image
 
        being NULL. Please fix your program.
 
-> make test gives the following output.
 
[[email protected] Apache-Gallery-0.6]# make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.6.1/i386-linux -I/usr/lib/perl5/5.6.1 -e 'use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
t/001_use...........Can't locate Test/More.pm in @INC (@INC contains: blib/arch blib/lib /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at t/001_use.t line 1.
BEGIN failed--compilation aborted at t/001_use.t line 1.
t/001_use...........dubious                                                 
        Test returned status 2 (wstat 512, 0x200)
t/002_graphlibs.....Can't locate Test/More.pm in @INC (@INC contains: blib/arch blib/lib /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at t/002_graphlibs.t line 1.
BEGIN failed--compilation aborted at t/002_graphlibs.t line 1.
t/002_graphlibs.....dubious                                                 
        Test returned status 2 (wstat 512, 0x200)
t/003_comment.......Can't locate Test/More.pm in @INC (@INC contains: blib/arch blib/lib /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at t/003_comment.t line 1.
BEGIN failed--compilation aborted at t/003_comment.t line 1.
t/003_comment.......dubious                                                 
        Test returned status 2 (wstat 512, 0x200)
t/004_cache_dir.....ok, 8/8 skipped: Test::MockObject not found             
Failed Test       Status Wstat Total Fail  Failed  List of Failed
--------------------------------------------------------------------------------
t/001_use.t                2   512    ??   ??       %  ??
t/002_graphlibs.t          2   512    ??   ??       %  ??
t/003_comment.t            2   512    ??   ??       %  ??
8 subtests skipped.
Failed 3/4 test scripts, 25.00% okay. 0/8 subtests failed, 100.00% okay.
make: *** [test_dynamic] Error 29
 
 
Anyone idea's ?
I have all the perl library's, all the imlib2 stuff is done via rpm's.