Mail Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fw: [ApacheGallery] Problem with a freshly installed apache::gallery



On Fri, Mar 08, 2002 at 04:10:08PM -0500, Paul Vallee wrote:
> Nope, it doesn't work. Sorry, we'll have to think of something else...

perldoc URI::Escape, it has the reason why it doesn't work ;-)

       uri_escape($string, [$unsafe])

             "\x00-\x1f\x7f-\xff"          # all control and hi-bit characters
             "a-z"                         # all lower case characters
             "^A-Za-z"                     # everything not a letter

Those are the escape rules, so I'm wondering why we actually aren't using
the default set of:
"^A-Za-z0-9\-_.!~*'()"

> Hi Michael,
> 
> Could you try George's suggestion? Is it equivalent?
> 
> I tried it on my install, and all is well. I can't find any difference in
> the app's behaviour, and I use single quotes, colons and spaces all over the
> place in my files and paths.
> Does it work on all the platforms you can test on?
> 
> Sorry, but regular expressions are far from a strong suit of mine.
> 
> Best regards,
> 
> Paul
> ----- Original Message -----
> From: "George Schlossnagle" <[email protected]>
> To: "Paul Vallee" <[email protected]>
> Sent: Friday, March 08, 2002 3:40 PM
> Subject: Re: Fw: [ApacheGallery] Problem with a freshly installed
> apache::gallery
> 
> 
> taking the lazy approach....
> 
> 
> what's wrong with $escape_rule = '\w\.';
> 
> what's the exact way you're using it later?
> 
> 
> On Friday, March 8, 2002, at 03:29 PM, Paul Vallee wrote:
> 
> > Any ideas?
> > TIA
> > Paul
> > ----- Original Message -----
> > From: "Michael Legart" <[email protected]>
> > To: <[email protected]>
> > Sent: Friday, March 08, 2002 3:35 AM
> > Subject: Re: [ApacheGallery] Problem with a freshly installed
> > apache::gallery
> >
> >
> > On Thu, Feb 28, 2002 at 10:52:39AM -0500, Paul Vallee wrote:
> >>
> >> my $escape_rule = '^a-zA-Z0-9\/_\\.';
> >> /usr/lib/perl5/site_perl/5.6.0/Apache/Gallery.pm line 136
> >
> > This is weird!
> >
> > '^a-zA-Z0-9/_\\.' fails with perl 5.6.0 but '^a-zA-Z0-9\/_\\.'
> > failes with 5.6.1!
> >
> > So what to do? I think we should use '^a-zA-Z0-9\/_\\.' because
> > it works with the latest stable perl, but I'm not sure?
> >
> > michael
> >
> > ---------------------------------------------------------------------
> > Apache::Gallery users mailinglist. http://apachegallery.dk/
> > To unsubscribe, e-mail: [email protected]
> >
> >
> >
> >
> >
> >
> // George Schlossnagle
> // Principal Consultant
> // OmniTI, Inc http://www.omniti.com
> // (c) 301.343.6422   (e) [email protected]
> // 1024D/1100A5A0 1370 F70A 9365 96C9 2F5E 56C2 B2B9 262F 1100 A5A0
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> Apache::Gallery users mailinglist. http://apachegallery.dk/
> To unsubscribe, e-mail: [email protected]
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> Apache::Gallery users mailinglist. http://apachegallery.dk/
> To unsubscribe, e-mail: [email protected]

-- 
  Thomas Eibner <http://thomas.eibner.dk/> DnsZone <http://dnszone.org/>
  mod_pointer <http://stderr.net/mod_pointer> <http://photos.eibner.dk/>
  !(C)<http://copywrong.dk/>                  <http://apachegallery.dk/>
          Putting the HEST in .COM <http://www.hestdesign.com/>

---------------------------------------------------------------------
Apache::Gallery users mailinglist. http://apachegallery.dk/
To unsubscribe, e-mail: [email protected]